Follow

Type to Learn 4 "No Internet connection was found..."

Important Update:

After December 31, 2016, phone support for Type to Learn 4 will be limited and users will be directed to our online support site.  As your hardware technology changes, Type to Learn 4 may not be compatible with future updates, patches, plugins and/or applications. All future updates will be applied to the next generation fully cloud-based application Type to Learn. Click here to learn more.

 

Symptom: When attempting to log-in you receive the error "No Internet connection was found. Please make sure you have an active connection and try again." 


Why?: This does not necessarily mean you do not have an internet connection but the client is unable to communicate with a listening server.

Solution:

If connecting using the Network version:

  1. For Windows, make sure that the Settings.ini file is pointed to the correct server IP address, using the port :3000, or no characters/spaces after the port number.
  2. Access the Windows Server and restart the TTL4onRails01 service.
  3. Make sure that there is an inbound port rule allowing any connection on the port 3000 in the Windows Firewall. Instructions for Creating Port Rule on Windows Server

Additional troubleshooting tips: you may also want to stop the service, and see what port number it stops at. If you see that it's different than :3000 (like maybe :3002, :3003, etc), you may want to try adding the new port number to your server ip in the .ini (example, 101.10.10.255:3002).

  1. For MAC servers, access the Applications > Sunburst > Output folder and run the StopServers.command and StartServers.command.Note: each of these files will prompt you for the MAC server password, continue to type it and press ENTER. After running both commands attempt to log-in.
  2. If you are behind a proxy server for Internet access, you will need to use the Type to Learn 4 Proxy Settings application in the program folder which will help you configure your proxy information.

________________________________________________________

If connecting using the Web-Enabled version:

Symptom: Program won't connect and/or web portal doesn't connect

  1. FIRST: open a browser - Chrome is the browser of choice. Go to ANY known common site, example google.com or microsoft.com, this is to establish yes, in fact your internet works correctly.
  2. If it does, then go to a new tab/browser and type in: teacher.ttl4.com
  3. Hit enter
  4. The web portal should open, if it does not, proceed to:
  5. Make sure the file called settings.ini is configured as below:

settings.ini

database=webservice 
serverUrl=http://teacher.ttl4.com <-- fix this line to say this 
version_major=1 
version_minor=1

Where is the settings.ini file located?

  • The path is c:\program files (or program files (x86) if using 64 bit windows)\sunburst\type to learn 4\
  • in there  will be the settings.ini.

Note: windows by default disables "common" suffixes of files, meaning if you just see settings, no .ini - that IS the file. You just click it to open it, edit the text, close, it will ask if you want to save, click yes, and that file is fixed.

--------------------------------

Next, make sure another ini file is fixed:

Prefs.ini

it should read:

AccountNumber= <--- change whatever is there to YOUR account number
LastValidUser=admin <--- this can be blank after equals, or admin 
ResolutionHeight=768  <---these are the rest of the settings
ResolutionWidth=1024
SoundFX=1
Volume=50
version_minor=0

  • the path to the prefs.ini is  c:\Users\(name of user logged in)\my documents\sunburst\type to learn 4\
  • in there will say prefs.ini or just prefs
  • Edit the same as with settings.ini, make your changes, close, yes to save, done.

This fixes most web enabled connectivity problems

 


 

Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk